summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-19 16:56:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-24 23:01:12 +0100
commit7c92efffe671d76e5e663b72a421778d9d1e5fdc (patch)
tree9b8cc596eec1864f181c9854b767b98e58b55e74 /gnu
parent8d422e258b12a9f263866938c1982251979f1b34 (diff)
gnu: Add Freepats.
* gnu/packages/audio.scm (freepats): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e1ad44a27c..b6c3a37ed9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,9 +23,12 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
#:use-module (guix build-system waf)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages glib)
@@ -190,6 +193,45 @@ bass section with five drawbars. A standalone JACK application and LV2
plugins are provided.")
(license license:gpl2)))
+(define-public freepats
+ (package
+ (name "freepats")
+ (version "20060219")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://freepats.zenvoid.org/freepats-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "12iw36rd94zirll96cd5k0va7p5hxmf2shvjlhzihcmjaw8flq82"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((out (string-append %output "/share/freepats")))
+ (setenv "PATH" (string-append
+ (assoc-ref %build-inputs "bzip2") "/bin:"
+ (assoc-ref %build-inputs "tar") "/bin"))
+ (system* "tar" "xvf" (assoc-ref %build-inputs "source"))
+ (chdir "freepats")
+ ;; Use absolute pattern references
+ (substitute* "freepats.cfg"
+ (("Tone_000") (string-append out "/Tone_000"))
+ (("Drum_000") (string-append out "/Drum_000")))
+ (mkdir-p out)
+ (copy-recursively "." out)))))
+ (native-inputs
+ `(("tar" ,tar)
+ ("bzip2" ,bzip2)))
+ (home-page "http://freepats.zenvoid.org")
+ (synopsis "GUS compatible patches for MIDI players")
+ (description
+ "FreePats is a project to create a free and open set of GUS compatible
+patches that can be used with softsynths such as Timidity and WildMidi.")
+ ;; GPLv2+ with exception for compositions using these patches.
+ (license license:gpl2+)))
+
(define-public jack-1
(package
(name "jack")