summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-03 08:22:10 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-04 15:41:30 +0200
commit7d88093f421b48ce5c13e389d7734462da7de4b5 (patch)
tree65f024655afae15c9282cd8a10f23b9e0caf88b2 /gnu
parent1e92287d41771765edd6e42513afc83c64d6df4e (diff)
gnu: Add python-rfc3987.
* gnu/packages/python.scm (python-rfc3987, python2-rfc3987): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9676e33445..df9503e38f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15100,3 +15100,24 @@ by path in a JSON document (see RFC 6901).")
(define-public python2-jsonpointer
(package-with-python2 python-jsonpointer))
+
+(define-public python-rfc3987
+ (package
+ (name "python-rfc3987")
+ (version "1.3.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rfc3987" version))
+ (sha256
+ (base32
+ "192pclzs2y0yaywqkrlvd0x73740q310kvqvm6jldhi619mq59wi"))))
+ (build-system python-build-system)
+ (home-page "http://pypi.python.org/pypi/rfc3987")
+ (synopsis "Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)")
+ (description "@code{rfc3987} provides routines for parsing and
+validation of URIs (see RFC 3986) and IRIs (see RFC 3987).")
+ (license license:gpl3+)))
+
+(define-public python2-rfc3987
+ (package-with-python2 python-rfc3987))