summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-10-15 20:00:03 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-10-17 13:47:41 -0400
commit82402f76bebfa3bb563a58227eb4081f9bdb6142 (patch)
tree7db98035399b9035f9b560dcf915c99efab22070 /gnu
parentc4d62443eb50a615d47b590a7fedcc7f7f0ec100 (diff)
gnu: hyperrogue: Update to 10.4t.
* gnu/packages/games.scm (hyperrogue): Update to 10.4t. [arguments]: Modify 'make-flags'. Modify 'configure' and 'install' phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm27
1 files changed, 16 insertions, 11 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2547c72c23..972dec3419 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3658,7 +3658,7 @@ throwing people around in pseudo-randomly generated buildings.")
(define-public hyperrogue
(package
(name "hyperrogue")
- (version "10.4j")
+ (version "10.4t")
;; When updating this package, be sure to update the "hyperrogue-data"
;; origin in native-inputs.
(source (origin
@@ -3669,11 +3669,12 @@ throwing people around in pseudo-randomly generated buildings.")
"-src.tgz"))
(sha256
(base32
- "0909p4xvbi1c2jc5rdgrf8b1c60fmsaapabsi6yyglh5znkf0k27"))))
+ "0phqhmnzmc16a23qb4fkil0flzb86kibdckf1r35nc3l0k4193nn"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
- #:make-flags '("CXXFLAGS=-std=c++11")
+ #:make-flags '("HYPERROGUE_USE_GLEW=1"
+ "HYPERROGUE_USE_PNG=1")
#:phases
(modify-phases %standard-phases
(add-after 'set-paths 'set-sdl-paths
@@ -3696,12 +3697,16 @@ throwing people around in pseudo-randomly generated buildings.")
(string-append dejavu-dir "/" dejavu-font)))
(substitute* music-file
(("\\*/")
- (string-append share-dir "/sounds/"))))
- ;; Fix Makefile.
- (substitute* "Makefile"
- (("g\\+\\+ langen.cpp")
- "g++ langen.cpp ${CXXFLAGS}")
- (("savepng.c") "savepng.cpp"))
+ (string-append share-dir "/sounds/")))
+ (substitute* "sound.cpp"
+ (("musicfile = \"\"")
+ (string-append "musicfile = \""
+ share-dir "/" music-file "\"")))
+ ;; Disable build machine CPU optimizations and warnings treated
+ ;; as errors.
+ (substitute* "Makefile"
+ (("-march=native") "")
+ (("-Werror") "")))
#t))
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -3709,7 +3714,7 @@ throwing people around in pseudo-randomly generated buildings.")
(bin (string-append out "/bin"))
(share-dir (string-append out "/share/hyperrogue")))
(mkdir-p bin)
- (copy-file "hyper" (string-append bin "/hyperrogue"))
+ (install-file "hyperrogue" bin)
(install-file "hyperrogue-music.txt" share-dir))
#t))
(add-after 'install 'install-data
@@ -3741,7 +3746,7 @@ throwing people around in pseudo-randomly generated buildings.")
"-win.zip"))
(sha256
(base32
- "0w61iv2rn93hi0q3hxyyyf9xcr8vi9zd7fjvpz5adpgf94jm3zsc"))))
+ "1xd9v8zzgi8m5ar8g4gy1xx5zqwidz3gn1knz0lwib3kbxx4drpg"))))
("unzip" ,unzip)))
(inputs
`(("font-dejavu" ,font-dejavu)