summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-20 16:41:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-20 19:31:53 +0100
commit85652f599a7a9574a26aefc4bdd36f6b6710a7c0 (patch)
tree8d546e1922510c0a7352348be81151b31aa1a9bc /gnu
parent5eb86b64d19ea1afeb1f6f21994a29ebbd9005b8 (diff)
gnu: Add HTSeq.
* gnu/packages/bioinformatics.scm (htseq): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c13e6499b7..b64dab73cd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -311,6 +311,30 @@ several alignment strategies enable effective alignment of RNA-seq reads, in
particular, reads spanning multiple exons.")
(license license:gpl3+)))
+(define-public htseq
+ (package
+ (name "htseq")
+ (version "0.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/H/HTSeq/HTSeq-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1i85ppf2j2lj12m0x690qq5nn17xxk23pbbx2c83r8ayb5wngzwv"))))
+ (build-system python-build-system)
+ (arguments `(#:python ,python-2)) ; only Python 2 is supported
+ (inputs
+ `(("python-numpy" ,python2-numpy)
+ ("python-setuptools" ,python2-setuptools)))
+ (home-page "http://www-huber.embl.de/users/anders/HTSeq/")
+ (synopsis "Analysing high-throughput sequencing data with Python")
+ (description
+ "HTSeq is a Python package that provides infrastructure to process data
+from high-throughput sequencing assays.")
+ (license license:gpl3+)))
+
(define-public rseqc
(package
(name "rseqc")