summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:39 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:16 -0700
commit87129984cac8b47b5d1be8d1257998611e3e9244 (patch)
tree4eef6ccd7548679c635dcd2bc76c7af9556c520e /gnu
parent4562c8c894b16dcea4875c4dea19565de9a4c34c (diff)
gnu: Add ghc-monadrandom.
* gnu/packages/haskell.scm (ghc-monadrandom): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 23c2d31326..ac807bee2b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9514,4 +9514,29 @@ statically known size.")
@code{ghc-contravariant} package.")
(license license:expat)))
+(define-public ghc-monadrandom
+ (package
+ (name "ghc-monadrandom")
+ (version "0.4.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "MonadRandom-" version "/"
+ "MonadRandom-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1h1nhswrcmhy3mq6vd530p0df51fcnnf4csbwnljar7cf0mb2h6y"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-primitive" ,ghc-primitive)
+ ("ghc-fail" ,ghc-fail)
+ ("ghc-random" ,ghc-random)))
+ (home-page "https://github.com/byorgey/MonadRandom")
+ (synopsis "Random-number generation monad for Haskell")
+ (description "This Haskell package provides support for computations
+which consume random values.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here