summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-06-13 14:34:31 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-06-13 14:44:13 -0400
commit935cb931b5ec850d691e27b2623c7a21e883d4b4 (patch)
treecaeecd962187dabe4fa0aff7cdfa21d204c1e335 /gnu
parent8c655f31db66a27730cae7c97ba001899143101b (diff)
gnu: emacspeak: Update to 48.0.
* gnu/packages/emacs.scm (emacspeak): Update to 48.0. [arguments]: Use 'invoke'. In the 'install' phase, add additional installation directories and fix the launch script substitution. [inputs]: Add emacs and perl. [native-inputs]: Remove emacs-minimal.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm36
1 files changed, 21 insertions, 15 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 039f52a560..51a8fc7f12 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5636,7 +5636,7 @@ highlights quasi-quoted expressions.")
(define-public emacspeak
(package
(name "emacspeak")
- (version "47.0")
+ (version "48.0")
(source
(origin
(method url-fetch)
@@ -5645,7 +5645,7 @@ highlights quasi-quoted expressions.")
version "/emacspeak-" version ".tar.bz2"))
(sha256
(base32
- "0xbcc266x752y68s3g096m161irzvsqym3axzqn8rb276a8x55n7"))))
+ "07imi3hji06b3r7v7v59978q76s8a7ynmxwfc9j03pgnv965lpjy"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list (string-append "prefix="
@@ -5653,30 +5653,35 @@ highlights quasi-quoted expressions.")
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda _
- ;; Configure Emacspeak according to etc/install.org.
- (setenv "SHELL" (which "sh"))
- (zero? (system* "make" "config"))))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lisp (string-append out
+ "/share/emacs/site-lisp/emacspeak")))
+ (setenv "SHELL" (which "sh"))
+ ;; Configure Emacspeak according to etc/install.org.
+ (invoke "make" "config"))))
(add-after 'build 'build-espeak
(lambda _
- (zero? (system* "make" "espeak"))))
+ (invoke "make" "espeak")))
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(lisp (string-append out "/share/emacs/site-lisp/emacspeak"))
- (info (string-append out "/share/info")))
+ (info (string-append out "/share/info"))
+ (emacs (string-append (assoc-ref inputs "emacs")
+ "/bin/emacs")))
;; According to etc/install.org, the Emacspeak directory should
;; be copied to its installation destination.
(for-each
(lambda (file)
(copy-recursively file (string-append lisp "/" file)))
- '("etc" "info" "lisp" "media" "servers" "sounds" "stumpwm"
- "xsl"))
+ '("etc" "info" "js" "lisp" "media" "scapes" "servers" "sounds"
+ "stumpwm" "xsl"))
;; Make sure emacspeak is loaded from the correct directory.
(substitute* "etc/emacspeak.sh"
- (("exec emacs.*$")
- (string-append "exec emacs -l " lisp
+ (("exec FLAVOR.*")
+ (string-append "exec " emacs " -l " lisp
"/lisp/emacspeak-setup.el $CL_ALL")))
;; Install the convenient startup script.
(mkdir-p bin)
@@ -5695,10 +5700,11 @@ highlights quasi-quoted expressions.")
#t))))
#:tests? #f)) ; no check target
(inputs
- `(("espeak" ,espeak)
+ `(("emacs" ,emacs)
+ ("espeak" ,espeak)
+ ("perl" ,perl)
("tcl" ,tcl)
("tclx" ,tclx)))
- (native-inputs `(("emacs" ,emacs-minimal)))
(home-page "http://emacspeak.sourceforge.net")
(synopsis "Audio desktop interface for Emacs")
(description