summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-18 09:51:27 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-19 16:43:31 -0500
commit97c821e030771b23ec8c120f664613aa4fb77ee3 (patch)
treed640671c4d5681867980689e9e2e5c2f9c5d9d86 /gnu
parent990e811c7346c13d677d8fbf4a1c1bc81faf15e5 (diff)
gnu: Add Cache-Cache.
* gnu/packages/perl.scm (perl-cache-cache): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7ffc4171c4..e31dd7d45d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -233,6 +233,33 @@ but don't want to go all out and profile your code.")
"Benchmark-Timer-" version))
(license gpl2)))
+(define-public perl-cache-cache
+ (package
+ (name "perl-cache-cache")
+ (version "1.08")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
+ "Cache-Cache-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1s6i670dc3yb6ngvdk48y6szdk5n1f4icdcjv2vi1l2xp9fzviyj"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-digest-sha1" ,perl-digest-sha1)
+ ("perl-error" ,perl-error)
+ ("perl-ipc-sharelite" ,perl-ipc-sharelite)))
+ (home-page "http://search.cpan.org/dist/Cache-Cache")
+ (synopsis "Cache interface for Perl")
+ (description "The Cache modules are designed to assist a developer in
+persisting data for a specified period of time. Often these modules are used
+in web applications to store data locally to save repeated and redundant
+expensive calls to remote machines or databases. People have also been known
+to use Cache::Cache for its straightforward interface in sharing data between
+runs of an application or invocations of a CGI-style script or simply as an
+easy to use abstraction of the filesystem or shared memory.")
+ (license (package-license perl))))
+
(define-public perl-capture-tiny
(package
(name "perl-capture-tiny")