summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:07:11 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:27 -0600
commit9c7d97c47d9a238800aaa565228c001205f7d45d (patch)
tree9e0cade2f170fbc16711a66a072dd2499a2ab8df /gnu
parent0bcb85be50724e3d0dc3f91646edf93114f8884d (diff)
gnu: Add Test-Harness.
* gnu/packages/perl.scm (perl-test-harness): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 25a53c96d6..7bdb93bb15 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -943,6 +943,36 @@ Test::Exception. It does much less, but should allow greater flexibility in
testing exception-throwing code with about the same amount of typing.")
(license (package-license perl))))
+(define-public perl-test-harness
+ (package
+ (name "perl-test-harness")
+ (version "3.35")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/L/LE/LEONT/"
+ "Test-Harness-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06l29y1bpizb9vd9g49lgi0wzj1xy4rsk42ahdj3fpgqnvb9wp05"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases (alist-cons-before
+ 'check 'patch-test
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; This test looks for "#!/usr/bin/perl" in some source.
+ ;; Patch what the test looks for.
+ (substitute* "t/source.t"
+ (("#!/usr/bin/perl")
+ (string-append "#!" (assoc-ref inputs "perl")
+ "/bin/perl"))))
+ %standard-phases)))
+ (home-page "http://search.cpan.org/dist/Test-Harness")
+ (synopsis "Run Perl standard test scripts with statistics")
+ (description "Simple test harness which allows tests to be run and results
+automatically aggregated and output to STDOUT.")
+ (license (package-license perl))))
+
(define-public perl-test-nowarnings
(package
(name "perl-test-nowarnings")