summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:05:11 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:27 -0600
commit9c8f076567f07c69b611aca1edd3b69e833898c5 (patch)
tree592fec6fb35ee580623d8cb00af3b9c8af338b61 /gnu
parent6eb28ece007ba60166933b72c4ac69706cbf933b (diff)
gnu: Add ExtUtils-InstallPaths.
* gnu/packages/perl.scm (perl-extutils-installpaths): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 26b27d46b8..282c7f82bc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -300,6 +300,27 @@ import(), @EXPORT and @EXPORT_OK and not a whole lot else.")
"Exporter-Lite-" version))
(license (package-license perl))))
+(define-public perl-extutils-installpaths
+ (package
+ (name "perl-extutils-installpaths")
+ (version "0.010")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/L/LE/LEONT/"
+ "ExtUtils-InstallPaths-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0mi1px42in7i442jqncg3gmxd5zn7sw5b2s85h690rz433qvyk6i"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-extutils-config" ,perl-extutils-config)))
+ (home-page "http://search.cpan.org/dist/ExtUtils-InstallPaths")
+ (synopsis "Build.PL install path logic made easy")
+ (description "This module tries to make install path resolution as easy as
+possible.")
+ (license (package-license perl))))
+
(define-public perl-extutils-config
(package
(name "perl-extutils-config")