summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-19 20:22:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 03:01:40 +0100
commit9f2eb4ffad8aecf8340013a8241de4127a080db8 (patch)
treebf920a5ad14476977f7e0801bd35533c28edab78 /gnu
parenteb67a470c7079694b5b75278b4806e018712610b (diff)
gnu: kmod: Update phase style.
* gnu/packages/linux.scm (kmod)[arguments]: Use MODIFY-PHASES syntax and end phase in #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ee76798419..53466765d3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1950,19 +1950,20 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
`(("xz" ,xz)
("zlib" ,zlib)))
(arguments
- `(#:tests? #f ; FIXME: Investigate test failures
+ `(#:tests? #f ; FIXME: Investigate test failures
#:configure-flags '("--with-xz" "--with-zlib")
- #:phases (alist-cons-after
- 'install 'install-modprobe&co
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (for-each (lambda (tool)
- (symlink "kmod"
- (string-append bin "/" tool)))
- '("insmod" "rmmod" "lsmod" "modprobe"
- "modinfo" "depmod"))))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-modprobe&co
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (for-each (lambda (tool)
+ (symlink "kmod"
+ (string-append bin "/" tool)))
+ '("insmod" "rmmod" "lsmod" "modprobe"
+ "modinfo" "depmod"))
+ #t))))))
(home-page "https://www.kernel.org/")
(synopsis "Kernel module tools")
(description "Kmod is a set of tools to handle common tasks with Linux