summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-05-12 09:36:38 -0400
committerTimothy Sample <samplet@ngyro.com>2019-05-12 20:01:35 -0400
commita430a3501a6d3a565cb78e04a8dbb3ab846ec5fc (patch)
tree4f083fbb127f6d11f53d977a73f01a5889d77ff5 /gnu
parent395c142ed967b3f5ae0c1b6a43d26f1c3e5cbdc9 (diff)
gnu: gdm: Fix configuration file discovery.
The configuration file loading code moved to a new file in version 2.28. * gnu/package/gnome.scm (gdm)[arguments]: Change the pre-configure phase to patch configuration file discovery into the 'gdm-settings.c' file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 44ae693be0..09984717cc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5655,8 +5655,8 @@ libxml2.")
"(self, \"" name "\","
"g_getenv (\"" name "\"));\n"))
propagate)))))
- ;; Look for custom GDM conf in /run/current-system.
- (substitute* '("common/gdm-settings-desktop-backend.c")
+ ;; Find the configuration file using an environment variable.
+ (substitute* '("common/gdm-settings.c")
(("GDM_CUSTOM_CONF")
(string-append "(g_getenv(\"GDM_CUSTOM_CONF\") != NULL"
" ? g_getenv(\"GDM_CUSTOM_CONF\")"