summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:24 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:14 -0700
commita51ba897743d28e8599cccf88c1aa86fa07f3dde (patch)
tree59afa3f17b1de8c3dee0a971c6d1de1b59de8a17 /gnu
parentbdd7e3950fba9ab2e49c0bc8be015556563bc4ba (diff)
gnu: Add ghc-math-functions.
* gnu/packages/haskell.scm (ghc-math-functions): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3226325025..0cc0d13fec 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9077,4 +9077,35 @@ error function, erf, and related functions. Instances for Float and
Double.")
(license license:bsd-3)))
+(define-public ghc-math-functions
+ (package
+ (name "ghc-math-functions")
+ (version "0.2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "math-functions-" version "/"
+ "math-functions-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1sv5vabsx332v1lpb6v3jv4zrzvpx1n7yprzd8wlcda5vsc5a6zp"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-vector" ,ghc-vector)
+ ("ghc-vector-th-unbox" ,ghc-vector-th-unbox)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-erf" ,ghc-erf)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "https://github.com/bos/math-functions")
+ (synopsis "Special functions and Chebyshev polynomials for Haskell")
+ (description "This Haskell library provides implementations of
+special mathematical functions and Chebyshev polynomials. These
+functions are often useful in statistical and numerical computing.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here