summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-04-27 22:49:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-05-01 18:15:59 +0200
commita66a60f251e38424078f2881522d0956e2f3643a (patch)
tree96385b13393f68cae533c8d0d01827d7cd44fe38 /gnu
parent2df092a93dd4a7718834aafadc729ccd9c3f3289 (diff)
gnu: Add synthv1.
* gnu/packages/music.scm (synthv1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cea685f705..f5ed8b8a59 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -689,6 +689,34 @@ your own lessons.")
Editor. It is compatible with Power Tab Editor 1.7 and Guitar Pro.")
(license license:gpl3+)))
+(define-public synthv1
+ (package
+ (name "synthv1")
+ (version "0.7.4")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/synthv1/synthv1-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "16n0v4jk0ilirq84rrildvdwqxgxav78rk58ilhl622v5n893c7w"))))
+ (build-system gnu-build-system)
+ ;; There are no tests.
+ (arguments `(#:tests? #f))
+ (inputs
+ `(("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("alsa-lib" ,alsa-lib)
+ ("liblo" ,liblo)
+ ("qt" ,qt)))
+ (home-page "http://synthv1.sourceforge.net")
+ (synopsis "Polyphonic subtractive synthesizer")
+ (description
+ "Synthv1 is an old-school subtractive polyphonic synthesizer with four
+oscillators and stereo effects.")
+ (license license:gpl2+)))
+
(define-public setbfree
(package
(name "setbfree")