summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:36 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:16 -0700
commitac4cb8fd7a94f7ba1892bbca197b5940d4dbe524 (patch)
tree08eebc299d8d4c50f07a2312d37f2e8cb6c5ce39 /gnu
parent371ad40c84a4764cfb08d53a555534025aca325e (diff)
gnu: Add ghc-base-prelude.
* gnu/packages/haskell.scm (ghc-base-prelude): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5573689ad0..7eb6946627 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9436,4 +9436,37 @@ representations for Haskell")
classy-prelude.")
(license license:expat)))
+(define-public ghc-base-prelude
+ (package
+ (name "ghc-base-prelude")
+ (version "1.2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "base-prelude-" version "/"
+ "base-prelude-" version ".tar.gz"))
+ (sha256
+ (base32
+ "17hivs7lmsglagdlzxd9q9zsddmgqin2788mpq911zwnb57lj6l1"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/nikita-volkov/base-prelude")
+ (synopsis "The most complete prelude formed solely from the Haskell's base
+package")
+ (description "This Haskell package aims to reexport all the non-conflicting
+and most general definitions from the \"base\" package.
+
+This includes APIs for applicatives, arrows, monoids, foldables, traversables,
+exceptions, generics, ST, MVars and STM.
+
+This package will never have any dependencies other than \"base\".
+
+Versioning policy:
+
+The versioning policy of this package deviates from PVP in the sense
+that its exports in part are transitively determined by the version of \"base\".
+Therefore it's recommended for the users of @code{ghc-base-prelude} to specify
+the bounds of \"base\" as well.")
+ (license license:expat)))
+
;;; haskell.scm ends here