summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-05-02 10:55:29 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-05-02 11:10:38 +0200
commitb74f64a960542b0679ab13de0dd28adc496cf084 (patch)
tree71e41267e31a5f04796cf6a1daea1292974f87c5 /gnu
parentcba962086da190b474df4f55bf2b50278f519640 (diff)
gnu: Add r-xnomial.
* gnu/packages/statistics.scm (r-xnomial): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 2178984d04..3d0faf7572 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1828,6 +1828,34 @@ documents (including DTDs), both local and accessible via HTTP or FTP. Also
offers access to an XPath \"interpreter\".")
(license license:bsd-2)))
+(define-public r-xnomial
+ (package
+ (name "r-xnomial")
+ (version "1.0.4")
+ (source
+ (origin (method url-fetch)
+ (uri (cran-uri "XNomial" version))
+ (sha256
+ (base32
+ "1mwx302576rmsjllbq2clfxilm3hkyp5bw0wmwqbn0kgv5wpy8z6"))))
+ (properties (quasiquote ((upstream-name . "XNomial"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/XNomial")
+ (synopsis "Goodness-of-Fit test for multinomial data")
+ (description
+ "This package provides an exact Goodness-of-Fit test for
+multinomial data with fixed probabilities. It can be used to
+determine whether a set of counts fits a given expected ratio. To see
+whether a set of observed counts fits an expectation, one can examine
+all possible outcomes with @code{xmulti()} or a random sample of them
+with @code{xmonte()} and find the probability of an observation
+deviating from the expectation by at least as much as the observed.
+As a measure of deviation from the expected, one can use the
+log-likelihood ratio, the multinomial probability, or the classic
+chi-square statistic. A histogram of the test statistic can also be
+plotted and compared with the asymptotic curve.")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-lambda-r
(package
(name "r-lambda-r")