summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-10 13:51:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-18 00:19:55 +0100
commitbe56161df16b7a6e72c88ff3a21177485fd93580 (patch)
treecb890b8e852eb8e91c94552e98c56572c4de99ad /gnu
parent245ce0cd5708e023737dbad9a3f007bbea30cb10 (diff)
gnu: Switch from damageproto to xorgproto.
* gnu/packages/xorg.scm (damageproto)[properties]: Mark as superseded by XORGPROTO. (libxdamage)[propagated-inputs]: Remove DAMAGEPROTO. (xorg-server)[inputs]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 63b045bc6a..d895f56387 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -297,8 +297,8 @@ the damage protocol.")
(description
"Damage Extension contains header files and documentation for
the damage protocol.")
- (license license:x11)))
-
+ (license license:x11)
+ (properties `((superseded . ,xorgproto)))))
(define-public dmxproto
(package
@@ -4519,8 +4519,7 @@ cannot be adequately worked around on the client side of the wire.")
(build-system gnu-build-system)
(propagated-inputs
;; These are all in the Requires or Requires.private field of xdamage.pc
- `(("damageproto" ,damageproto)
- ("libxfixes" ,libxfixes)
+ `(("libxfixes" ,libxfixes)
("xorgproto" ,xorgproto)
("libx11" ,libx11)))
(native-inputs
@@ -5109,8 +5108,7 @@ over Xlib, including:
("xf86driproto" ,xf86driproto)
("xorgproto" ,xorgproto)))
(inputs
- `(("damageproto" ,damageproto)
- ("udev" ,eudev)
+ `(("udev" ,eudev)
("dbus" ,dbus)
("libdmx" ,libdmx)
("libepoxy" ,libepoxy)