summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-11-09 13:14:33 -0500
committerKei Kebreau <kkebreau@posteo.net>2017-11-12 01:17:10 -0500
commitc7b433de474d873d135187fc9676e8112254b450 (patch)
treef9e0be9af7999f9a19190cd536993730a092d9de /gnu
parent1e2a36e1b0ec087a99aaf553fd69a3bd85961275 (diff)
gnu: glib-networking: Update to 2.54.1.
* gnu/packages/gnome.scm (glib-networking): Update to 2.54.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 172f09e9b7..4088ffb0f2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2326,7 +2326,7 @@ library.")
(define-public glib-networking
(package
(name "glib-networking")
- (version "2.50.0")
+ (version "2.54.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/glib-networking/"
@@ -2334,7 +2334,7 @@ library.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1vkb53jxawy38y29635izlch64j9xmcwwcimk134jwra7hpl86iz"))
+ "0bq16m9nh3gcz9x2fvygr0iwxd2pxcbrm3lj3kihsnh1afv8g9za"))
(patches
(search-patches "glib-networking-ssl-cert-file.patch"))))
(build-system gnu-build-system)
@@ -2344,18 +2344,19 @@ library.")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-giomoduledir
- ;; Install GIO modules into $out/lib/gio/modules.
- (lambda _
- (substitute* "configure"
- (("GIO_MODULE_DIR=.*")
- (string-append "GIO_MODULE_DIR=" %output
- "/lib/gio/modules\n")))))
+ ;; Install GIO modules into $out/lib/gio/modules.
+ (lambda _
+ (substitute* "configure"
+ (("GIO_MODULE_DIR=.*")
+ (string-append "GIO_MODULE_DIR=" %output
+ "/lib/gio/modules\n")))
+ #t))
(add-before 'check 'use-empty-ssl-cert-file
- (lambda _
- ;; The ca-certificates.crt is not available in the build
- ;; environment.
- (setenv "SSL_CERT_FILE" "/dev/null")
- #t)))))
+ (lambda _
+ ;; The ca-certificates.crt is not available in the build
+ ;; environment.
+ (setenv "SSL_CERT_FILE" "/dev/null")
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))