summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-03 08:22:14 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-04 15:41:53 +0200
commitd270df8d627aba2e7de4ded1a212735196a5585c (patch)
tree2c7072737c554a1a87ad81907a36ad2ff5c34ec5 /gnu
parent235bc01b283915bfa479cbf2bd646f8e09dde6d7 (diff)
gnu: Add python-bottle.
* gnu/packages/python.scm (python-bottle, python2-bottle): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ef884edddb..7cbeeb6fe0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15199,3 +15199,23 @@ complex datatypes to and from native Python datatypes.")
(define-public python2-marshmallow
(package-with-python2 python-marshmallow))
+
+(define-public python-bottle
+ (package
+ (name "python-bottle")
+ (version "0.12.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bottle" version))
+ (sha256
+ (base32
+ "0m9k2a7yxvggc4kw8fsvj381vgsvfcdshg5nzy6vwrxiw2p53drr"))))
+ (build-system python-build-system)
+ (home-page "http://bottlepy.org/")
+ (synopsis "WSGI framework for small web-applications.")
+ (description "@code{python-bottle} is a WSGI framework for small web-applications.")
+ (license license:expat)))
+
+(define-public python2-bottle
+ (package-with-python2 python-bottle))