summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-01 17:00:51 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-01 17:56:58 +0100
commitd29f0007cb392b4cd7267ca53990b9455810bb43 (patch)
tree39d72bc5547c649a2a99c3aa8398e16f44d09d14 /gnu
parent4c8a06607453c09fc75b42ba97318e803c543985 (diff)
gnu: iptables: Update to 1.8.6.
* gnu/packages/linux.scm (iptables): Update to 1.8.6. [arguments]: Remove obsolete #:phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 17126047ab..d25e46ce05 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2182,8 +2182,7 @@ external rate conversion.")
(define-public iptables
(package
(name "iptables")
- ;; XXX When updating, remove the ‘install-missing-script’ phase.
- (version "1.8.5")
+ (version "1.8.6")
(source
(origin
(method url-fetch)
@@ -2192,7 +2191,7 @@ external rate conversion.")
(string-append "https://www.netfilter.org/projects/iptables/"
"files/iptables-" version ".tar.bz2")))
(sha256
- (base32 "02a3575ypdpg6a2x752mhk3f7h1381ymkq1n0gss6fp6292xfmyl"))))
+ (base32 "0rvp0k8a72h2snrdx48cfn75bfa0ycrd2xl3kjysbymq7q6gxx50"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -2204,19 +2203,7 @@ external rate conversion.")
(arguments
'(#:tests? #f ; no test suite
#:configure-flags ; add $libdir to the RUNPATH of executables
- (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-missing-script
- ;; A typo prevents installation of /sbin/iptables-apply. It's been
- ;; fixed upstream (d4ed0c741fc789bb09d977d74d30875fdd50d08b), but
- ;; a patch would require bootstrapping and more inputs. Simply copy
- ;; the file ourselves.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (sbin (string-append out "/sbin")))
- (install-file "iptables/iptables-apply" sbin)
- #t))))))
+ (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
(home-page "https://www.netfilter.org/projects/iptables/index.html")
(synopsis "Programs to configure Linux IP packet filtering rules")
(description