summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-01 23:57:44 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-03 00:11:06 -0500
commitdb29ee0b1b3fafc51a18247a118a10149e8cdb4f (patch)
treef50150bae08da2acd61eedb9c1f5e23bf1be003c /gnu
parent0c96afe9b54592ea1018e081d4124e4bfed473e5 (diff)
gnu: samba: Set localstatedir to /var.
It previously defaulted to a $PREFIX/var, where $PREFIX was the root of the installation directory (under /gnu/store) of Samba. * gnu/packages/samba.scm (samba)[phases]{configure}: Add --localstatedir=/var option. {disable-etc-samba-directory-creation}: Rename to disable-etc,var-samba-directories-setup and prevent creating directories under both sysconfdir and localstatedir.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/samba.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 719ca29303..9f1945db0b 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -221,15 +221,15 @@ external dependencies.")
"--bundled-libraries=com_err"
(string-append "--prefix=" out)
"--sysconfdir=/etc"
+ "--localstatedir=/var"
;; Install public and private libraries into
;; a single directory to avoid RPATH issues.
(string-append "--libdir=" libdir)
(string-append "--with-privatelibdir=" libdir)))))
- (add-before 'install 'disable-etc-samba-directory-creation
+ (add-before 'install 'disable-etc,var-samba-directories-setup
(lambda _
(substitute* "dynconfig/wscript"
- (("bld\\.INSTALL_DIR\\(\"\\$\\{CONFIGDIR\\}\"\\)")
- ""))
+ (("bld\\.INSTALL_DIR.*") ""))
#t)))
;; XXX: The test infrastructure attempts to set password with
;; smbpasswd, which fails with "smbpasswd -L can only be used by root."