summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-02 15:35:37 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-02 15:39:10 +0200
commite0649ff3c0db17a27999da36cf9bd9fead8df4c7 (patch)
tree89ea3fb90af2eb4e38fd053b89e938c862d93e6c /gnu
parent67fcf2358c2d592a471b7e5aae993aeb4cfc29a0 (diff)
gnu: gawk: Update to 4.1.4.
* gnu/packages/gawk.scm (gawk): Update to 4.1.4. [source]: Remove 'patches'. [arguments]: Add 'adjust-test-infrastructure' phase. * gnu/packages/patches/gawk-fts-test.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gawk.scm22
-rw-r--r--gnu/packages/patches/gawk-fts-test.patch51
3 files changed, 18 insertions, 56 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1aada2a7b9..8b882269e3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -512,7 +512,6 @@ dist_patch_DATA = \
%D%/packages/patches/fontforge-svg-modtime.patch \
%D%/packages/patches/fossil-test-fixes.patch \
%D%/packages/patches/freeimage-CVE-2015-0852.patch \
- %D%/packages/patches/gawk-fts-test.patch \
%D%/packages/patches/gawk-shell.patch \
%D%/packages/patches/gcc-arm-link-spec-fix.patch \
%D%/packages/patches/gcc-cross-environment-variables.patch \
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index c6d322b708..9852f760e0 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -29,14 +29,13 @@
(define-public gawk
(package
(name "gawk")
- (version "4.1.3")
+ (version "4.1.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gawk/gawk-" version
".tar.xz"))
(sha256
- (base32 "09d6pmx6h3i2glafm0jd1v1iyrs03vcyv2rkz12jisii3vlmbkz3"))
- (patches (search-patches "gawk-fts-test.patch"))))
+ (base32 "0rn2mmjxm767zliqzd67j7h2ncjn4j0321c60y9fy3grs3i89qak"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f ; test suite fails in parallel
@@ -59,7 +58,22 @@
(string-append "### " match))))
'())))
- %standard-phases)))
+ (alist-cons-before
+ 'check 'adjust-test-infrastructure
+ (lambda _
+ ;; Remove dependency on 'more' (from util-linux), which
+ ;; would needlessly complicate bootstrapping.
+ (substitute* "test/Makefile"
+ (("\\| more") ""))
+
+ ;; Adjust the shebang in that file since it is then diff'd
+ ;; against the actual test output.
+ (substitute* "test/watchpoint1.ok"
+ (("#! /usr/bin/gawk")
+ (string-append "#!" (which "gawk"))))
+ #t)
+
+ %standard-phases))))
(inputs `(("libsigsegv" ,libsigsegv)
,@(if (%current-target-system)
diff --git a/gnu/packages/patches/gawk-fts-test.patch b/gnu/packages/patches/gawk-fts-test.patch
deleted file mode 100644
index de1f5c431c..0000000000
--- a/gnu/packages/patches/gawk-fts-test.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-This is upstream commit c9a018c. We have observed random failures of
-this test on i686 that seem related to load.
-
-2015-05-21 Arnold D. Robbins <arnold@skeeve.com>
-
- * fts.awk: Really remove atime from the output.
- This avoids spurious failures on heavily loaded systems.
-
-diff --git a/test/fts.awk b/test/fts.awk
-index b1df060..dea5b68 100644
---- a/test/fts.awk
-+++ b/test/fts.awk
-@@ -50,6 +50,11 @@ function sort_traverse(data, sorted, i)
- {
- asorti(data, sorted)
- for (i = 1; i in sorted; i++) {
-+ # 5/2015: skip for atime, since there can
-+ # occasionally be small differences.
-+ if (sorted[i] == "atime")
-+ continue
-+
- indent()
- printf("%s --> %s\n", sorted[i], data[sorted[i]]) > output
- }
-@@ -63,17 +68,20 @@ function traverse(data, i)
- printf("%s:\n", i) > output
-
- Level++
-- if (("mtime" in data[i]) && ! isarray(data[i][mtime])) {
-+ if (("mtime" in data[i]) && ! isarray(data[i]["mtime"])) {
- sort_traverse(data[i])
- } else {
- traverse(data[i])
- }
- Level--
-- } else if (data[i] != "atime") {
-- # 4/2015: skip for atime, since there can
-- # occasionally be small differences.
-- indent()
-- printf("%s --> %s\n", i, data[i]) > output
-+# } else {
-+# JUNK = 1
-+# if (i != "atime") {
-+# # 4/2015: skip for atime, since there can
-+# # occasionally be small differences.
-+# indent()
-+# printf("%s --> %s\n", i, data[i]) > output
-+# }
- }
- }
- }