summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:42 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:16 -0700
commite2f6116e782aa705161095e0ae792d395dadaea3 (patch)
tree57badb4930439885b81cffd5ccbdd3ea823d6d76 /gnu
parent933e78045d24ebf76f8b0cb33d16c85efd7c1cac (diff)
gnu: Add ghc-crypto-api.
* gnu/packages/haskell.scm (ghc-crypto-api): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3a64aa450e..ad86fc1ce8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9589,4 +9589,35 @@ which consume random values.")
to obtain cryptographically strong entropy.")
(license license:bsd-3)))
+(define-public ghc-crypto-api
+ (package
+ (name "ghc-crypto-api")
+ (version "0.13.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "crypto-api-" version "/"
+ "crypto-api-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vc27qcgbg7hf50rkqhlrs58zn1888ilh4b6wrrm07bnm48xacak"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-cereal" ,ghc-cereal)
+ ("ghc-tagged" ,ghc-tagged)
+ ("ghc-entropy" ,ghc-entropy)))
+ (home-page "https://github.com/TomMD/crypto-api")
+ (synopsis "Provides generic interface for cryptographic operations
+for Haskell")
+ (description "This Haskell package provides a generic interface for
+cryptographic operations (hashes, ciphers, randomness).
+
+Maintainers of hash and cipher implementations are encouraged to add instances
+for the classes defined in @code{Crypto.Classes}. @code{Crypto} users are
+similarly encouraged to use the interfaces defined in the @code{Classes} module.
+
+Any concepts or functions of general use to more than one cryptographic
+algorithm (ex: padding) is within scope of this package.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here