summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-15 22:36:05 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-27 20:55:39 +0100
commite7d2c60809827182e9f716ab5de2e5ad77d7c252 (patch)
treea6477fcc9eebdaec2bbdb18ee2557e4daa5610b4 /gnu
parentb7e9ee3327be03f5bc529cfb90b31da1b5586d4c (diff)
gnu: qemu: Add dependency on Samba.
* gnu/packages/qemu.scm (qemu-kvm): Add dependency on Samba; pass `--smbd' to ./configure.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qemu.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index e6859aadf0..785d470079 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages libjpeg)
#:use-module (gnu packages attr)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages samba)
#:use-module (gnu packages perl))
(define-public qemu-kvm
@@ -52,14 +53,17 @@
(lambda* (#:key inputs outputs #:allow-other-keys)
;; The `configure' script doesn't understand some of the
;; GNU options. Thus, add a new phase that's compatible.
- (let ((out (assoc-ref outputs "out")))
+ (let ((out (assoc-ref outputs "out"))
+ (samba (assoc-ref inputs "samba")))
(setenv "SHELL" (which "bash"))
;; The binaries need to be linked against -lrt.
(setenv "LDFLAGS" "-lrt")
(zero?
(system* "./configure"
- (string-append "--prefix=" out)))))
+ (string-append "--prefix=" out)
+ (string-append "--smbd=" samba
+ "/sbin/smbd")))))
%standard-phases)))
(inputs ; TODO: Add optional inputs.
`(;; ("mesa" ,mesa)
@@ -76,7 +80,8 @@
;; ("alsa-lib" ,alsa-lib)
;; ("SDL" ,SDL)
("zlib" ,zlib)
- ("attr" ,attr)))
+ ("attr" ,attr)
+ ("samba" ,samba))) ; an optional dependency
(home-page "http://www.linux-kvm.org/")
(synopsis
"Virtualization for Linux on x86 hardware containing virtualization extensions")