summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-31 13:20:19 -0400
committerLeo Famulari <leo@famulari.name>2016-05-31 13:38:40 -0400
commite88eb07110a9e6bf49bfe9020ad9a9a08c2dd61b (patch)
treedefd153c304d009603687ce01005fdc43c3c8695 /gnu
parent4d93a76138246ba1f9d6f81da4039e89e14570be (diff)
gnu: imagemagick: Fix CVE-2016-5118.
* gnu/packages/patches/imagemagick-CVE-2016-5118.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/imagemagick.scm (imagemagick): Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/imagemagick.scm1
-rw-r--r--gnu/packages/patches/imagemagick-CVE-2016-5118.patch29
3 files changed, 31 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f669167091..21f9f81d10 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -552,6 +552,7 @@ dist_patch_DATA = \
%D%/packages/patches/icu4c-CVE-2015-4760.patch \
%D%/packages/patches/id3lib-CVE-2007-4460.patch \
%D%/packages/patches/ilmbase-fix-tests.patch \
+ %D%/packages/patches/imagemagick-CVE-2016-5118.patch \
%D%/packages/patches/inkscape-drop-wait-for-targets.patch \
%D%/packages/patches/irrlicht-mesa-10.patch \
%D%/packages/patches/jansson-CVE-2016-4425.patch \
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index dc03ea48a4..1549497483 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -46,6 +46,7 @@
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
+ (patches (search-patches "imagemagick-CVE-2016-5118.patch"))
(sha256
(base32
"0niwa7ci50865x1h6qffz1q6i2ph2l5ym7bhcg5kdnvi4f75p9ir"))))
diff --git a/gnu/packages/patches/imagemagick-CVE-2016-5118.patch b/gnu/packages/patches/imagemagick-CVE-2016-5118.patch
new file mode 100644
index 0000000000..0df4ce57ca
--- /dev/null
+++ b/gnu/packages/patches/imagemagick-CVE-2016-5118.patch
@@ -0,0 +1,29 @@
+From c0c5c9fc7271fd141531b0bdb55b7f7ff5afc481 Mon Sep 17 00:00:00 2001
+From: Leo Famulari <leo@famulari.name>
+Date: Tue, 31 May 2016 13:06:10 -0400
+Subject: [PATCH] Fix CVE-2016-5118.
+
+This is the temporary fix suggested by upstream:
+https://www.imagemagick.org/discourse-server/viewtopic.php?f=2&t=29803#p134039
+---
+ magick/magick-baseconfig.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/magick/magick-baseconfig.h b/magick/magick-baseconfig.h
+index d320f2a..c9cce82 100644
+--- a/magick/magick-baseconfig.h
++++ b/magick/magick-baseconfig.h
+@@ -519,7 +519,10 @@
+
+ /* Define to 1 if you have the `popen' function. */
+ #ifndef MAGICKCORE_HAVE_POPEN
++/* Temporary mitigation for CVE-2016-5118 (popen() shell vulnerability via
++ * filename)
+ #define MAGICKCORE_HAVE_POPEN 1
++*/
+ #endif
+
+ /* Define to 1 if you have the `posix_fadvise' function. */
+--
+2.8.3
+