summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-24 10:20:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-24 10:33:05 +0200
commitebde7c7a9be91a8546c24730fdb29823fe27acb2 (patch)
treee83b8c73ae343a91c7c564cf2b7bfd6c5efaa385 /gnu
parent778a6a8bf0bc5c558fba5d141897cee7065e2b92 (diff)
mplayer: Use 'modify-phases'.
* gnu/packages/video.scm (mplayer)[arguments]: Use 'modify-phases'. [source]: Use https. [home-page]: Use https.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2e3ca71a0a..1649de3304 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -608,7 +608,7 @@ treaming protocols.")
(source (origin
(method url-fetch)
(uri (string-append
- "http://www.mplayerhq.hu/MPlayer/releases/MPlayer-"
+ "https://www.mplayerhq.hu/MPlayer/releases/MPlayer-"
version ".tar.xz"))
(sha256
(base32
@@ -652,8 +652,8 @@ treaming protocols.")
(arguments
`(#:tests? #f ; no test target
#:phases
- (alist-replace
- 'configure
+ (modify-phases %standard-phases
+ (replace 'configure
;; configure does not work followed by "SHELL=..." and
;; "CONFIG_SHELL=..."; set environment variables instead
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -667,7 +667,7 @@ treaming protocols.")
"./configure"
(string-append "--extra-cflags=-I"
libx11 "/include") ; to detect libx11
- "--disable-ffmpeg_a" ; disables bundled ffmpeg
+ "--disable-ffmpeg_a" ; disables bundled ffmpeg
(string-append "--prefix=" out)
;; Enable runtime cpu detection where supported,
;; and choose a suitable target.
@@ -686,9 +686,8 @@ treaming protocols.")
(or (%current-target-system)
(nix-system->gnu-triplet
(%current-system)))))))
- "--disable-iwmmxt"))))
- %standard-phases)))
- (home-page "http://www.mplayerhq.hu/design7/news.html")
+ "--disable-iwmmxt"))))))))
+ (home-page "https://www.mplayerhq.hu/design7/news.html")
(synopsis "Audio and video player")
(description "MPlayer is a movie player. It plays most MPEG/VOB, AVI,
Ogg/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4, RealMedia, Matroska, NUT,