summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 15:56:41 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:27 -0600
commitf57c76863912d97af4102b2a8249aaf71446cb5f (patch)
treefaf2626eca0f6549bf51c0ccb888820940e4a2a7 /gnu
parentcab88488e937e677d1b0aef39a5ca926a54eced2 (diff)
gnu: Add Number-Compare.
* gnu/packages/perl.scm (perl-number-compare): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index caa129264b..c8480d8d49 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -485,6 +485,25 @@ cycle. Functions called in the package itself will still be bound by their
name, but they won't show up as methods on your class or instances.")
(license (package-license perl))))
+(define-public perl-number-compare
+ (package
+ (name "perl-number-compare")
+ (version "0.03")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RC/RCLAMP/"
+ "Number-Compare-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09q8i0mxvr7q9vajwlgawsi0hlpc119gnhq4hc933d03x0vkfac3"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Number-Compare")
+ (synopsis "Numeric comparisons")
+ (description "Number::Compare compiles a simple comparison to an anonymous
+subroutine, which you can call with a value to be tested against.")
+ (license (package-license perl))))
+
(define-public perl-package-anon
(package
(name "perl-package-anon")