summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-10 13:56:55 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-23 10:17:35 +0100
commitf9e62ad221a9f059f78b4f2800d48cf893de10dd (patch)
treeca3c8c4d9900a1adcd7637047e740aa199ee3afb /gnu
parente73b49fbd6c3028c3175b982efeb3f819963dc55 (diff)
gnu: icedtea6: patch ant shebang in unpack phase
* gnu/packages/java.scm (icedtea6)[arguments]: patch bootstrap ant in the `unpack' phase instead of `patch-paths'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 29f628ca38..7f841f090b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -184,6 +184,7 @@ build process and its dependencies, whereas Make uses Makefile format.")
(zero? (system* "tar" "xvjf"
(assoc-ref inputs "ant-bootstrap")))
(begin
+ (patch-shebang "apache-ant-1.9.4/bin/ant")
(chdir (string-append ,name "-" ,version))
(mkdir "openjdk")
(with-directory-excursion "openjdk"
@@ -193,8 +194,6 @@ build process and its dependencies, whereas Make uses Makefile format.")
(alist-cons-after
'unpack 'patch-paths
(lambda _
- (patch-shebang "../apache-ant-1.9.4/bin/ant")
-
;; shebang in patches so that they apply cleanly
(substitute* '("patches/jtreg-jrunscript.patch"
"patches/hotspot/hs23/drop_unlicensed_test.patch")