summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Hashe <david.hashe@dhashe.com>2015-02-19 18:47:55 -0600
committerMark H Weaver <mhw@netris.org>2015-02-19 23:14:21 -0500
commitfc936b65d351f0a73af066f1c9874ed8b08cef7c (patch)
tree911af85efde61c195ab869d83741e7e14b4f88bd /gnu
parent9953fa7602a0f59e28cc67f8f38ab4b311040e74 (diff)
gnu: Add gnugo.
* gnu/packages/games.scm (gnugo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9b8983e848..687e037526 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -834,3 +835,27 @@ straight into any libretro-compatible frontend. RetroArch is the official
reference frontend for the libretro API, currently used by most as a modular
multi-system game/emulator system.")
(license license:gpl3+)))
+
+(define-public gnugo
+ (package
+ (name "gnugo")
+ (version "3.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gnugo/gnugo-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0wkahvqpzq6lzl5r49a4sd4p52frdmphnqsfdv7gdp24bykdfs6s"))))
+ (build-system gnu-build-system)
+ (inputs `(("readline" ,readline)))
+ (synopsis "Go game")
+ (description "GNU Go is a program that plays the game of Go, in which
+players place stones on a grid to form territory or capture other stones.
+While it can be played directly from the terminal, rendered in ASCII
+characters, it is also possible to play GNU Go with 3rd party graphical
+interfaces or even in Emacs. It supports the standard game storage format
+(SGF, Smart Game Format) and inter-process communication format (GMP, Go
+Modem Protocol).")
+ (home-page "http://www.gnu.org/software/gnugo/")
+ (license license:gpl3+)))