summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-26 16:40:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-26 16:40:42 +0100
commitfdc316f3741e2f4174235e1828d62552da7559d4 (patch)
tree23c6c480be36ffbbf4e624ab2cfe443b10e2d5de /gnu
parent9ac17c62421ba6239ca2654fb5c4170e8cb4749e (diff)
gnu: trim-galore: Update to 0.6.1.
* gnu/packages/bioinformatics.scm (trim-galore): Update to 0.6.1. [arguments]: Adjust patching.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 87f15fc7f2..4e799f2fc4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10880,17 +10880,17 @@ with narrow binding events such as transcription factor ChIP-seq.")
(define-public trim-galore
(package
(name "trim-galore")
- (version "0.4.5")
+ (version "0.6.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/FelixKrueger/TrimGalore.git")
(commit version)))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0x5892l48c816pf00wmnz5vq0zq6170d3xc8zrxncd4jcz7h1p71"))))
+ "1y31wbxwkm9xqzr5zv1pk5q418whnmlmgmfyxxpnl12h83m2i9iv"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -10905,10 +10905,10 @@ with narrow binding events such as transcription factor ChIP-seq.")
(string-append "$path_to_cutadapt = '"
(assoc-ref inputs "cutadapt")
"/bin/cutadapt'"))
- (("\\| gzip")
- (string-append "| "
+ (("\\$compression_path = \"gzip\"")
+ (string-append "$compression_path = \""
(assoc-ref inputs "gzip")
- "/bin/gzip"))
+ "/bin/gzip\""))
(("\"gunzip")
(string-append "\""
(assoc-ref inputs "gzip")