summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-03 19:24:33 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-05 16:37:51 +0100
commitffe8c06e89c9703cad4bdd1dde363042125f1cad (patch)
tree8e9165b6e9085b0a5a69ece88a0036b9be7d91f4 /gnu
parent35deff72863587079b194dcca56368473a8b0e29 (diff)
gnu: ghc-fingertree: Run tests.
* gnu/packages/haskell.scm (ghc-fingertree)[arguments]: Delete to run tests. [native-inputs]: Add ghc-hunit, ghc-quickcheck, ghc-test-framework, ghc-test-framework-hunit, and ghc-test-framework-quickcheck2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e483960ff4..9e58a6a532 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3584,7 +3584,12 @@ will eventually deliver a value of type @code{a}.")
(base32
"1ryjj7qrx70ckcjlr02x9zh86kfp76azbxq05r7hawqkaqg44sfs"))))
(build-system haskell-build-system)
- (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
(home-page "https://hackage.haskell.org/package/fingertree")
(synopsis "Generic finger-tree structure")
(description "This library provides finger trees, a general sequence