summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-10-15 16:16:12 -0400
committerJulien Lepiller <julien@lepiller.eu>2020-10-20 00:22:56 +0200
commit51e7e72bca9622560cde27db785b2d3e3fe058ae (patch)
tree423c135791855cac621d27aa3463767719a83612 /gnu
parent6010fde5e9f3e655433c60689b00d02c664ef63c (diff)
gnu: gajim: Make some cosmetic changes.
* gnu/packages/messaging.scm (gajim): Make some cosmetic changes. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm54
1 files changed, 29 insertions, 25 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1342cf7c0c..adfeee6be4 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -734,14 +734,15 @@ of xmpppy.")
(package
(name "gajim")
(version "1.1.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://gajim.org/downloads/"
- (version-major+minor version)
- "/gajim-" version ".tar.bz2"))
- (sha256
- (base32
- "0bzxwcpdd4ydh6d6mzpr0gxwhcb0x9ympk55fpvm1hcw9d28a716"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://gajim.org/downloads/"
+ (version-major+minor version)
+ "/gajim-" version ".tar.bz2"))
+ (sha256
+ (base32 "0bzxwcpdd4ydh6d6mzpr0gxwhcb0x9ympk55fpvm1hcw9d28a716"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -800,22 +801,25 @@ else [])"))
"/share/glib-2.0/schemas"))))
#t)))))
(native-search-paths
- (list (search-path-specification
- (variable "GAJIM_PLUGIN_PATH")
- (separator #f) ;single entry
- (files '("share/gajim/plugins")))
- ;; Gajim needs to use the propagated inputs of its plugins.
- (search-path-specification
- (variable "PYTHONPATH")
- (files (list (string-append
- "lib/python"
-
- ;; FIXME: Cannot use this expression as it would
- ;; introduce a circular dependency at the top level.
- ;; (version-major+minor (package-version python))
- "3.8"
-
- "/site-packages"))))))
+ (list
+ (search-path-specification
+ (variable "GAJIM_PLUGIN_PATH")
+ (separator #f) ;single entry
+ (files
+ (list
+ "share/gajim/plugins")))
+ ;; Gajim needs to use the propagated inputs of its plugins.
+ (search-path-specification
+ (variable "PYTHONPATH")
+ (files
+ (list
+ (string-append
+ "lib/python"
+ ;; FIXME: Cannot use this expression as it would
+ ;; introduce a circular dependency at the top level.
+ ;; (version-major+minor (package-version python))
+ "3.8"
+ "/site-packages"))))))
(native-inputs
`(("intltool" ,intltool)
("python-docutils" ,python-docutils)
@@ -838,13 +842,13 @@ else [])"))
("python-pygobject" ,python-pygobject)
("python-pyopenssl" ,python-pyopenssl)
("python-qrcode" ,python-qrcode)))
- (home-page "https://gajim.org/")
(synopsis "Jabber (XMPP) client")
(description "Gajim is a feature-rich and easy to use Jabber/XMPP client.
Among its features are: a tabbed chat window and single window modes; support
for group chat (with Multi-User Chat protocol), invitation, chat to group chat
transformation; audio and video conferences; file transfer; TLS, GPG and
end-to-end encryption support; XML console.")
+ (home-page "https://gajim.org/")
(license license:gpl3)))
(define-public gajim-omemo