summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-22 12:13:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-22 12:15:50 +0200
commitad85d0d536d3a3bde06fed06b936a4213cee9c98 (patch)
tree0c08420b782f203eeb05661dc69cc330289f155a /gnu
parent22f8260ba16e77c9f20bfd49f7fa3269f0c51d1b (diff)
gnu: r-zvcv: Update to 2.1.0.
* gnu/packages/cran.scm (r-zvcv): Update to 2.1.0. [propagated-inputs]: Remove r-partitions; add r-bh, r-dplyr, r-magrittr, and r-rlinsolve.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f0cb55c152..1c530c5c73 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21334,23 +21334,26 @@ linear systems can be manageable using the @code{Matrix} package along with
(define-public r-zvcv
(package
(name "r-zvcv")
- (version "1.0.0")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "ZVCV" version))
(sha256
(base32
- "1npw836q2skx54843lgxvb0rfwafckjc8k8dljykm60ad3z7zak8"))))
+ "0np6h6x74kz1x13wmbkkm1wq43d8bnn2khzjc80prqdi6n0m9v8r"))))
(properties `((upstream-name . "ZVCV")))
(build-system r-build-system)
(propagated-inputs
`(("r-abind" ,r-abind)
+ ("r-bh" ,r-bh)
+ ("r-dplyr" ,r-dplyr)
("r-glmnet" ,r-glmnet)
+ ("r-magrittr" ,r-magrittr)
("r-mvtnorm" ,r-mvtnorm)
- ("r-partitions" ,r-partitions)
("r-rcpp" ,r-rcpp)
- ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-rlinsolve" ,r-rlinsolve)))
(home-page "https://cran.r-project.org/web/packages/ZVCV/")
(synopsis "Zero-Variance Control Variates")
(description