summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-05-31 13:33:14 -0400
committerDavid Thompson <davet@gnu.org>2016-06-03 08:54:25 -0400
commitc5c08f1b1ea1a2adde4f746209cdea0e8696c4e3 (patch)
tree553793b70d08fab68dc726bcc5c4f7e0bbe004a4 /gnu
parentad1c453731d5b320fbd94c6486bf0bc96a4e7e7a (diff)
gnu: Add emacs-smex.
* gnu/packages/emacs.scm (emacs-smex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b7c0a1f5fd..71f2f8b531 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 humanitiesNerd <catonano@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1795,3 +1796,24 @@ work on lists, strings and vectors.")
Emacs default configuration in uncontroversial ways that nearly everyone can
agree upon.")
(license license:gpl3+)))
+
+(define-public emacs-smex
+ (package
+ (name "emacs-smex")
+ (version "3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://raw.githubusercontent.com"
+ "/nonsequitur/smex/" version "/smex.el"))
+ (file-name (string-append "smex-" version ".el"))
+ (sha256
+ (base32
+ "0ar310zx9k5y4i1vl2rawvi712xj9gx77160860jbs691p77cxqp"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/nonsequitur/smex/")
+ (synopsis "M-x interface with Ido-style fuzzy matching")
+ (description
+ "Smex is a M-x enhancement for Emacs. Built on top of Ido, it provides a
+convenient interface to your recently and most frequently used commands. And
+to all the other commands, too.")
+ (license license:gpl3+)))