summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-27 01:05:18 +0200
committerRoel Janssen <roel@gnu.org>2018-04-27 01:11:42 +0200
commitcbd9f91c326f5f57fb9dd4374069b215e2e7a5f6 (patch)
tree13ce0a19b17498434a2c17fb92593e2ebc69a1d0 /gnu
parent8df0267ad4cef8e86ac34a8e3b95cd1ef6177efb (diff)
gnu: bcftools: Update to 1.8.
* gnu/packages/bioinformatics.scm (bcftools): Update to 1.8. * gnu/local.mk: Remove patch. * gnu/packages/patches/bcftools-regidx-unsigned-char.patch: Remove file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm7
-rw-r--r--gnu/packages/patches/bcftools-regidx-unsigned-char.patch16
3 files changed, 3 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6065d4c96b..3e093b791b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -575,7 +575,6 @@ dist_patch_DATA = \
%D%/packages/patches/azr3.patch \
%D%/packages/patches/bash-completion-directories.patch \
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
- %D%/packages/patches/bcftools-regidx-unsigned-char.patch \
%D%/packages/patches/binutils-ld-new-dtags.patch \
%D%/packages/patches/binutils-loongson-workaround.patch \
%D%/packages/patches/blast+-fix-makefile.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fc5fe41115..d8b17f51e4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -285,7 +285,7 @@ BAM files.")
(define-public bcftools
(package
(name "bcftools")
- (version "1.5")
+ (version "1.8")
(source (origin
(method url-fetch)
(uri (string-append
@@ -293,12 +293,11 @@ BAM files.")
version "/bcftools-" version ".tar.bz2"))
(sha256
(base32
- "0093hkkvxmbwfaa7905s6185jymynvg42kq6sxv7fili11l5mxwz"))
- (patches (search-patches "bcftools-regidx-unsigned-char.patch"))
+ "1vgw2mwngq20c530zim52zvgmw1lci8rzl33pvh44xqk3xlzvjsa"))
(modules '((guix build utils)))
(snippet
;; Delete bundled htslib.
- '(delete-file-recursively "htslib-1.5"))))
+ '(delete-file-recursively "htslib-1.8"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
diff --git a/gnu/packages/patches/bcftools-regidx-unsigned-char.patch b/gnu/packages/patches/bcftools-regidx-unsigned-char.patch
deleted file mode 100644
index af5bc160f5..0000000000
--- a/gnu/packages/patches/bcftools-regidx-unsigned-char.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: Fix test-regidx argument parsing on archs with unsigned char
- On architectures where char is unsigned "c >= 0" was always true.
-Author: Adrian Bunk <bunk@debian.org>
-Bug-Debian: https://bugs.debian.org/865060
-
---- a/test/test-regidx.c
-+++ b/test/test-regidx.c
-@@ -336,7 +336,7 @@
- {"seed",1,0,'s'},
- {0,0,0,0}
- };
-- char c;
-+ int c;
- int seed = (int)time(NULL);
- while ((c = getopt_long(argc, argv, "hvs:",loptions,NULL)) >= 0)
- {