summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-24 01:27:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-01-08 20:12:01 +0100
commitd1ce1125b80b0dfba4b665293a6bb0c611025584 (patch)
tree58665b4036427563f3104dbb76709766eb08017c /gnu
parentd7603bbbbe652853ae6ea3198eb810d0d66ac77b (diff)
gnu: Add rename.
* gnu/packages/admin.scm (rename): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d90bc7c050..81df265362 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,6 +43,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
@@ -756,6 +758,31 @@ console window to allow commands to be interactively run on multiple servers
over ssh connections.")
(license license:gpl2+)))
+(define-public rename
+ (package
+ (name "rename")
+ (version "0.20")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RM/RMBARKER/File-Rename-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1cf6xx2hiy1xalp35fh8g73j67r0w0g66jpcbc6971x9jbm7bvjy"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (home-page "https://metacpan.org/pod/distribution/File-Rename/rename.PL")
+ (synopsis "Perl extension for renaming multiple files")
+ (description
+ "This package provides a Perl interface (@code{Perl::Rename}) as well
+as a command-line utility (@command{rename}) that can rename multiple files
+at once based on a Perl regular expression.")
+ (license license:perl-license)))
+
(define-public rottlog
(package
(name "rottlog")