summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-22 12:42:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-22 12:42:19 +0200
commitd30ab75a7d74f9cddb29b3f87c214085a5dba3ac (patch)
tree5cadfde8252fb60903b4c3a740a49ef3fe6b1873 /gnu
parent5c1aab1dc152ea8327a74a459417bc4d780993e7 (diff)
gnu: r-directlabels: Move to (gnu packages cran).
* gnu/packages/statistics.scm (r-directlabels): Move this variable from here... * gnu/packages/cran.scm (r-directlabels): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
-rw-r--r--gnu/packages/statistics.scm24
2 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dc181d435a..53b2338a06 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22166,3 +22166,27 @@ algorithm. It finds relevant features by comparing original attributes'
importance with importance achievable at random, estimated using their
permuted copies (shadows).")
(license license:gpl2+)))
+
+(define-public r-directlabels
+ (package
+ (name "r-directlabels")
+ (version "2020.1.31")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "directlabels" version))
+ (sha256
+ (base32
+ "08s1gnwp4bn8xahwjaq0f1qzhwh2dvybzhq3z7xyzn8cnyzmis6c"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-quadprog" ,r-quadprog)))
+ (home-page "http://directlabels.r-forge.r-project.org/")
+ (synopsis "Direct labels for multicolor plots")
+ (description
+ "This package provides an extensible framework for automatically placing
+direct labels onto multicolor plots. Label positions are described using
+positioning methods that can be re-used across several different plots. There
+are heuristics for examining @code{trellis} and @code{ggplot} objects and
+inferring an appropriate positioning method.")
+ (license license:gpl3)))
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index cc4e7ac4c8..91734cd449 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5638,30 +5638,6 @@ tools.")
parameters.")
(license license:gpl3))))
-(define-public r-directlabels
- (package
- (name "r-directlabels")
- (version "2020.1.31")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "directlabels" version))
- (sha256
- (base32
- "08s1gnwp4bn8xahwjaq0f1qzhwh2dvybzhq3z7xyzn8cnyzmis6c"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-quadprog" ,r-quadprog)))
- (home-page "http://directlabels.r-forge.r-project.org/")
- (synopsis "Direct labels for multicolor plots")
- (description
- "This package provides an extensible framework for automatically placing
-direct labels onto multicolor plots. Label positions are described using
-positioning methods that can be re-used across several different plots. There
-are heuristics for examining @code{trellis} and @code{ggplot} objects and
-inferring an appropriate positioning method.")
- (license license:gpl3)))
-
(define-public r-catterplots
(let ((commit "ae17cd5e49ddda4ecfe0eba8a4c21df8c88e72c4")
(revision "3"))