summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-09-27 17:29:31 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-09-27 17:29:31 +0200
commitd753aee0be51800d70aa16c6e60506303b2cbb49 (patch)
tree807f83daa0f0c62ca4cd673817b399023fc8288b /gnu
parentf1f076c9dc53a5905ee6ed4b608de4463550d971 (diff)
gnu: bbswitch-module: Fix build on Linux >= 5.6.
* gnu/packages/linux.scm (bbswitch-module): Update to 20200526.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm43
1 files changed, 23 insertions, 20 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b936613144..38ab0fe3a6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1166,27 +1166,30 @@ between the CDemu userspace daemon and linux kernel.")
(license license:gpl2+)))
(define-public bbswitch-module
- (package
- (name "bbswitch-module")
- (version "0.8")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Bumblebee-Project/bbswitch")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1glch4j0x1dzlp2yrb67v2r5jg9609jb6p8m251y78m74advqw0l"))))
- (build-system linux-module-build-system)
- (arguments
- ;; No tests.
- `(#:tests? #f))
- (home-page "https://github.com/Bumblebee-Project/bbswitch")
- (synopsis "Kernel module that disables discrete Nvidia graphics cards")
- (description "The bbswitch module provides a way to toggle the Nvidia
+ ;; Use "develop" branch since stable release does not build on Linux >= 5.6.
+ ;; See https://github.com/Bumblebee-Project/bbswitch/issues/205.
+ (let ((commit "ddbd243638c7bc2baecf43a78aff46cdc12e9b2e"))
+ (package
+ (name "bbswitch-module")
+ (version (git-version "0.8" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Bumblebee-Project/bbswitch")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pgldnza7mzd0flrxg4q69dwbq1fhl58m5c62ary5drb0xyf3lqb"))))
+ (build-system linux-module-build-system)
+ (arguments
+ ;; No tests.
+ `(#:tests? #f))
+ (home-page "https://github.com/Bumblebee-Project/bbswitch")
+ (synopsis "Kernel module that disables discrete Nvidia graphics cards")
+ (description "The bbswitch module provides a way to toggle the Nvidia
graphics card on Optimus laptops.")
- (license license:gpl2)))
+ (license license:gpl2))))
(define-public ddcci-driver-linux
(package