summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-19 17:30:44 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-19 18:14:22 +0100
commitf6396d862f9f8ce0c0e6894ce30599773167af0c (patch)
treeb7c3bd56c7799309136421bc587e7d1ebee5e967 /gnu
parent8df672aad5dc8d93da750c96f472ba2155d51da1 (diff)
gnu: Rename "guile-next" to "guile".
* gnu/packages/guile.scm (guile-next): Rename to... (guile-2.2): ... this. Update users. [name]: Change to "guile". [synopsis]: Remove. [properties]: Remove 'upstream-name', 'ftp-server', and 'ftp-directory'. * gnu/packages/bioinformatics.scm (rcas-web): Update accordingly. * gnu/packages/tls.scm (gnutls/guile-2.2): Likewise. * tests/guix-build.sh: Use 'guile@2.2' instead of 'guile-next'. * doc/guix.texi (Package Transformation Options): Update examples that referred to "guile-next".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/guile.scm26
-rw-r--r--gnu/packages/tls.scm2
3 files changed, 13 insertions, 17 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ccde01b119..90092ddf70 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7638,7 +7638,7 @@ library implementing most of the pipeline's features.")
(inputs
`(("r-minimal" ,r-minimal)
("r-rcas" ,r-rcas)
- ("guile-next" ,guile-next)
+ ("guile-next" ,guile-2.2)
("guile-json" ,guile2.2-json)
("guile-redis" ,guile2.2-redis)))
(native-inputs
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9289c40a76..c172fd3fc1 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -231,9 +231,9 @@ without requiring the source code to be rewritten.")
"12yqkr974y91ylgw6jnmci2v90i90s7h9vxa4zk0sai8vjnz4i1p"))
(patches (search-patches "guile-repl-server-test.patch"))))))
-(define-public guile-next
+(define-public guile-2.2
(package (inherit guile-2.0)
- (name "guile-next")
+ (name "guile")
(version "2.2.0")
(replacement #f)
(source (origin
@@ -250,12 +250,8 @@ without requiring the source code to be rewritten.")
;; times (almost 3 hours on a 4-core Intel i5).
(snippet '(for-each delete-file
(find-files "prebuilt" "\\.go$")))))
- (synopsis "Snapshot of what will become version 2.2 of GNU Guile")
(properties '((timeout . 72000) ;20 hours
- (max-silent-time . 10800) ;3 hours (needed on ARM)
- (upstream-name . "guile")
- (ftp-server . "alpha.gnu.org")
- (ftp-directory . "/gnu/guile")))
+ (max-silent-time . 10800))) ;3 hours (needed on ARM)
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")
@@ -276,12 +272,12 @@ applicable."
(define package-for-guile-2.2
;; A procedure that rewrites the dependency tree of the given package to use
- ;; GUILE-NEXT instead of GUILE-2.0.
- (package-input-rewriting `((,guile-2.0 . ,guile-next))
+ ;; GUILE-2.2 instead of GUILE-2.0.
+ (package-input-rewriting `((,guile-2.0 . ,guile-2.2))
guile-2.2-package-name))
(define-public guile-for-guile-emacs
- (package (inherit guile-next)
+ (package (inherit guile-2.2)
(name "guile-for-guile-emacs")
(version "20150510.d8d9a8d")
(source (origin
@@ -296,7 +292,7 @@ applicable."
(substitute-keyword-arguments `(;; Tests aren't passing for now.
;; Obviously we should re-enable this!
#:tests? #f
- ,@(package-arguments guile-next))
+ ,@(package-arguments guile-2.2))
((#:phases phases)
`(modify-phases ,phases
(add-after 'unpack 'autogen
@@ -314,7 +310,7 @@ applicable."
("flex" ,flex)
("texinfo" ,texinfo)
("gettext" ,gettext-minimal)
- ,@(package-native-inputs guile-next)))
+ ,@(package-native-inputs guile-2.2)))
;; Same as in guile-2.0
(native-search-paths
(list (search-path-specification
@@ -1641,7 +1637,7 @@ and then run @command{scm example.scm}.")
(build-system gnu-build-system)
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
- ("guile" ,guile-next)
+ ("guile" ,guile-2.2)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
(arguments
@@ -1657,7 +1653,7 @@ and then run @command{scm example.scm}.")
"GNU 8sync (pronounced \"eight-sync\") is an asynchronous programming
library for GNU Guile based on the actor model.
-Note that 8sync is only available for Guile 2.2 (guile-next in Guix).")
+Note that 8sync is only available for Guile 2.2.")
(license license:lgpl3+)))
(define-public guile-fibers
@@ -1676,7 +1672,7 @@ Note that 8sync is only available for Guile 2.2 (guile-next in Guix).")
`(("texinfo" ,texinfo)
("pkg-config" ,pkg-config)))
(inputs
- `(("guile" ,guile-next)))
+ `(("guile" ,guile-2.2)))
(synopsis "Lightweight concurrency facility for Guile")
(description
"Fibers is a Guile library that implements a a lightweight concurrency
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 32aa7a61dc..9c7cb0b0ca 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -238,7 +238,7 @@ required structures.")
(substitute-keyword-arguments (package-arguments gnutls-3.5.8)
((#:configure-flags flags)
`(cdr ,flags))))
- (inputs `(("guile" ,guile-next)
+ (inputs `(("guile" ,guile-2.2)
,@(alist-delete "guile" (package-inputs gnutls-3.5.8))))))
(define-public openssl