summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-09-14 09:21:32 +0300
committerAndrew Tropin <andrew@trop.in>2022-09-14 18:25:12 +0300
commit0336372296e676f97799d6a3a1e9cf209f14c6bc (patch)
tree3a66603e8b1041cb2e7732a72927fa8c47d6a997 /gnu
parent6cdde65bb53b439f25f007df238f549ba2debc72 (diff)
gnu: emacs-kv: Fix build.
Build fails with emacs-next cause of copypasted test defined two times. * gnu/packages/patches/emacs-kv-fix-tests.patch: New file. * gnu/packages/emacs-xyz.scm (emacs-kv): Use it here. * gnu/local.mk (dist_patch_DATA): Register it here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs-xyz.scm4
-rw-r--r--gnu/packages/patches/emacs-kv-fix-tests.patch30
3 files changed, 34 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index adaa709b3e..bc4594146a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1051,6 +1051,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-telega-test-env.patch \
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
%D%/packages/patches/emacs-yasnippet-fix-tests.patch \
+ %D%/packages/patches/emacs-kv-fix-tests.patch \
%D%/packages/patches/enjarify-setup-py.patch \
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
%D%/packages/patches/erlang-man-path.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 53672377b1..3311e973e6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17951,7 +17951,9 @@ formatting rules for that language.")
(file-name (git-file-name name version))
(sha256
(base32
- "0r0lz2s6gvy04fwnafai668jsf4546h4k6zd6isx5wpk0n33pj5m"))))
+ "0r0lz2s6gvy04fwnafai668jsf4546h4k6zd6isx5wpk0n33pj5m"))
+ (patches
+ (search-patches "emacs-kv-fix-tests.patch"))))
(build-system emacs-build-system)
(arguments
`(#:tests? #t
diff --git a/gnu/packages/patches/emacs-kv-fix-tests.patch b/gnu/packages/patches/emacs-kv-fix-tests.patch
new file mode 100644
index 0000000000..35a6bf004c
--- /dev/null
+++ b/gnu/packages/patches/emacs-kv-fix-tests.patch
@@ -0,0 +1,30 @@
+From 4702849bfe7462fb6c6303786dac1b670c8f0f8f Mon Sep 17 00:00:00 2001
+From: Andrew Tropin <andrew@trop.in>
+Date: Wed, 14 Sep 2022 09:17:31 +0300
+Subject: [PATCH] remove copypasted kvaq test
+
+---
+ kv-tests.el | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/kv-tests.el b/kv-tests.el
+index 1713e5e..abd6a24 100644
+--- a/kv-tests.el
++++ b/kv-tests.el
+@@ -105,13 +105,6 @@
+ (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
+ (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
+
+-(ert-deftest kvaq ()
+- "Test the simple assq."
+- (should (equal :b (kvaq :a '((:a . :b)("a" . "b")))))
+- (should (equal 2 (kvaq 1 '((1 . 2)("a" . "b")))))
+- (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
+- (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
+-
+ (ert-deftest kvaqc ()
+ "Test the simple assq."
+ (should (equal :b (kvaqc :a '((:a . :b)("a" . "b")))))
+--
+2.37.3
+