summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSiniša Biđin <sinisa@bidin.eu>2015-08-18 22:40:08 +0200
committerEric Bavier <bavier@member.fsf.org>2015-08-23 16:49:57 -0500
commit05b964ae85a5f0661358c879bb954407c0cfb4ce (patch)
treee525929d65e6b22453b56f496fb84cc863dda0a9 /gnu
parenteb6ae860e53568fa224c4c689af5aae7aeaf3383 (diff)
gnu: Add ghc-extensible-exceptions.
* gnu/packages/haskell.scm (ghc-extensible-exceptions): New variable. Signed-off-by: Eric Bavier <bavier@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 225ebbc9e7..e0960a82b2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -348,6 +348,26 @@ particularly useful for efficient logging and pretty printing (e.g. with the
Writer monad), where list append quickly becomes too expensive.")
(license bsd-3)))
+(define-public ghc-extensible-exceptions
+ (package
+ (name "ghc-extensible-exceptions")
+ (version "0.1.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "extensible-exceptions/extensible-exceptions-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1273nqws9ij1rp1bsq5jc7k2jxpqa0svawdbim05lf302y0firbc"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/extensible-exceptions")
+ (synopsis "Extensible exceptions for Haskell")
+ (description
+ "This package provides extensible exceptions for both new and old
+versions of GHC (i.e., < 6.10).")
+ (license bsd-3)))
+
(define-public ghc-mtl
(package
(name "ghc-mtl")