summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 11:29:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:57 +0100
commit0b13a75716136aac6ffee5f1f10bec77393a1ca7 (patch)
tree71dc79c0d1ae378c6db36c19306979df795406de /gnu
parent2a1fd51864826dd983194a16a49a9e0220f02454 (diff)
gnu: Add r-adagio.
* gnu/packages/cran.scm (r-adagio): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6b64e797ea..bebf4acbe4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18326,3 +18326,26 @@ classifiers. Once these classifiers have been trained, they can be used to
predict on new data. Also, cross validation estimation of the error can be
done.")
(license license:gpl2+)))
+
+(define-public r-adagio
+ (package
+ (name "r-adagio")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "adagio" version))
+ (sha256
+ (base32
+ "1h9l0ddrxq8y35iy9hdkxdvdwsqpnpkzzbkbwwhm4380lq1m7a3k"))))
+ (properties `((upstream-name . "adagio")))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://cran.r-project.org/web/packages/adagio/")
+ (synopsis "Discrete and global optimization routines")
+ (description
+ "This package provides methods and algorithms for discrete optimization,
+e.g. knapsack and subset sum procedures, derivative-free Nelder-Mead and
+Hooke-Jeeves minimization, and some (evolutionary) global optimization
+functions.")
+ (license license:gpl3+)))