summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-15 18:13:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-15 18:13:39 +0200
commit0b58cb427db55ec710d54330191cf9b4ebab3e6e (patch)
tree72ac010edb52b68400be4ca877bf6105367c9238 /gnu
parentb5b56b7f27dc902721ce23dfcbbbf777026186e8 (diff)
gnu: python-datrie: Update to 0.8.
* gnu/packages/python-xyz.scm (python-datrie): Update to 0.8. [arguments]: Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e58acc3578..21f8a916d6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5860,23 +5860,15 @@ of the structure, dynamics, and functions of complex networks.")
(define-public python-datrie
(package
(name "python-datrie")
- (version "0.7.1")
+ (version "0.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "datrie" version))
(sha256
(base32
- "08r0if7dry2q7p34gf7ffyrlnf4bdvnprxgydlfxgfnvq8f3f4bs"))))
+ "0338r8xgmpy78556jhms0h6qkvyjr10p8bpgdvcpqzm9lrmxmmdx"))))
(build-system python-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'build 'cythonize
- (lambda _
- ;; Regenerate Cython classes to solve ABI issues with Python
- ;; 3.7.0. See <https://github.com/pytries/datrie/issues/52>.
- (invoke "cython" "src/datrie.pyx" "src/cdatrie.pxd"
- "src/stdio_ext.pxd" "-a"))))))
(native-inputs
`(("python-cython" ,python-cython)
("python-hypothesis" ,python-hypothesis)