summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2019-05-30 00:02:38 -0700
committerRicardo Wurmus <rekado@elephly.net>2019-05-30 11:50:05 +0200
commit169d63f53307f16743166c25f709d37fcbc47262 (patch)
tree90774e7d50ad39e6743c89df3db1ef82259629ef /gnu
parentdc37301330af38c7f3b7d6d10d1a3557335c0642 (diff)
gnu: Add gthumb.
* gnu/packages/gnome.scm (gthumb): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 14e63280ed..60141fce9b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7974,3 +7974,50 @@ functionality.")
(license (list license:lgpl2.1 license:lgpl3 ; either one of these
license:openldap2.8 ; addressbook/gui/component/openldap-extract.h
license:lgpl2.1+)))) ; smime/lib/*
+
+(define-public gthumb
+ (package
+ (name "gthumb")
+ (version "3.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gthumb/"
+ (version-major+minor version) "/"
+ "gthumb-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1l2s1facq1r6yvqjqc34aqfzlvb3nhkhn79xisxbbdlgrrxdq52f"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ ;; Ensure the RUNPATH contains all installed library locations.
+ (list (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib/gthumb/extensions")
+ (string-append "-Dcpp_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib/gthumb/extensions"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
+ ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)))
+ (inputs
+ `(("exiv2" ,exiv2)
+ ("gtk" ,gtk+)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gstreamer" ,gstreamer)
+ ("clutter" ,clutter)
+ ("clutter-gst" ,clutter-gst)
+ ("clutter-gtk" ,clutter-gtk)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("libraw" ,libraw)))
+ (home-page "https://wiki.gnome.org/Apps/Gthumb")
+ (synopsis "GNOME image viewer and browser")
+ (description "GThumb is an image viewer, browser, organizer, editor and
+advanced image management tool")
+ (license license:gpl2+)))