summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-26 18:05:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-26 18:06:35 +0100
commit28d32817d82fb0d4da6bd274b9c5446ddb1d7f45 (patch)
treebe017ce51a2672d592b022bbfbcca162cf23231d /gnu
parent8c9372c1243cdb49f7bbf94ec3d001c02b736325 (diff)
gnu: python-scanpy: Update to 1.4.
* gnu/packages/bioinformatics.scm (python-scanpy): Update to 1.4. [source]: Fetch from git. [arguments]: Disable broken tests. [native-inputs]: Add python-pytest. [home-page]: Use HTTPS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm38
1 files changed, 33 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4e799f2fc4..0001a82e4b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13266,15 +13266,41 @@ in RNA-seq data.")
(define-public python-scanpy
(package
(name "python-scanpy")
- (version "1.2.2")
+ (version "1.4")
+ ;; Fetch from git because the pypi tarball does not include tests.
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "scanpy" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/theislab/scanpy.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ak7bxms5a0yvf65prppq2g38clkv7c7jnjbnfpkh3xxv7q512jz"))))
+ "0zn6x6c0cnm1a20i6isigwb51g3pr9zpjk8r1minjqnxi5yc9pm4"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; These tests require Internet access.
+ (delete-file-recursively "scanpy/tests/notebooks")
+ (delete-file "scanpy/tests/test_clustering.py")
+
+ ;; TODO: No module named 'louvain'
+ (delete-file "scanpy/tests/test_rank_genes_groups_logreg.py")
+
+ ;; TODO: I can't get the plotting tests to work, even with Xvfb.
+ (delete-file "scanpy/tests/test_plotting.py")
+ (delete-file "scanpy/tests/test_preprocessing.py")
+ (delete-file "scanpy/tests/test_read_10x.py")
+
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) ":"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest")
+ #t)))))
(propagated-inputs
`(("python-anndata" ,python-anndata)
("python-igraph" ,python-igraph)
@@ -13290,7 +13316,9 @@ in RNA-seq data.")
("python-seaborn" ,python-seaborn)
("python-h5py" ,python-h5py)
("python-tables" ,python-tables)))
- (home-page "http://github.com/theislab/scanpy")
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/theislab/scanpy")
(synopsis "Single-Cell Analysis in Python.")
(description "Scanpy is a scalable toolkit for analyzing single-cell gene
expression data. It includes preprocessing, visualization, clustering,