summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-14 05:23:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-22 01:06:02 +0100
commit34e8cf225cc380c2f248eecd43151f6751eeda97 (patch)
tree75ed132b5b7c39c5d39aacf68136da9e1969bf08 /gnu
parent82d57f126c87f11acf08e7834b9f135cce849b45 (diff)
gnu: Add lunzip.
* gnu/packages/compression.scm (lunzip): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 86d27f8a47..543d8ab7b9 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1942,3 +1942,30 @@ type by using either Perl modules, or command-line tools on your system.")
(description "Tukaani-xz is an implementation of xz compression/decompression
algorithms in Java.")
(license license:public-domain)))
+
+(define-public lunzip
+ (package
+ (name "lunzip")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.savannah.gnu.org/releases/lzip/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ax3d9cp66z1qb9q7lfzg5bpx9630xrxgq9a5sw569wm0qqgpg2q"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "CC=gcc")))
+ (home-page "http://www.nongnu.org/lzip/lunzip.html")
+ (synopsis "Small, stand-alone lzip decompressor")
+ (description
+ "Lunzip is a decompressor for files in the lzip compression format (.lz),
+written as a single small C tool with no dependencies. This makes it
+well-suited to embedded and other systems without a C++ compiler, or for use in
+applications such as software installers that need only to decompress files,
+not compress them.
+Lunzip is intended to be fully compatible with the regular lzip package.")
+ (license (list license:bsd-2 ; carg_parser.[ch]
+ license:gpl2+)))) ; everything else