summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-29 15:41:00 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-29 15:44:14 +0200
commit373a2a07975ed8e187f3baaa5c795a7ff0fd155b (patch)
treef7375c6308c657ed85c40326f1f076be4e7a5b0e /gnu
parentfdd9ab372153ac31382175957cead9eb1ca27c0e (diff)
gnu: ocaml-yojson: Update to 1.7.0.
* gnu/packages/ocaml.scm (ocaml-yojson): Update to 1.7.0. (ocaml-merlin): Use jbuild to prevent a build failure due to a deprecation warning.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index efba539fa8..affdff2a67 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3470,18 +3470,18 @@ than yojson), with 25-35% space savings.")
(define-public ocaml-yojson
(package
(name "ocaml-yojson")
- (version "1.4.1")
+ (version "1.7.0")
(home-page "https://github.com/ocaml-community/yojson")
(source
(origin
(method git-fetch)
(uri (git-reference
(url (string-append home-page ".git"))
- (commit (string-append "v" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "0nwsfkmqpyfab4rxq76q8ff7giyanghw08094jyrp275v99zdjr9"))))
+ "0zncsw8bgbkh1pfvfc7nh628hfj84lgx6jwhp9ashj3z1z0w3xjn"))))
(build-system dune-build-system)
(arguments
`(#:test-target "."))
@@ -3489,7 +3489,8 @@ than yojson), with 25-35% space savings.")
`(("ocaml-biniou" ,ocaml-biniou)
("ocaml-easy-format" ,ocaml-easy-format)))
(native-inputs
- `(("ocaml-cppo" ,ocaml-cppo)))
+ `(("ocaml-alcotest" ,ocaml-alcotest)
+ ("ocaml-cppo" ,ocaml-cppo)))
(synopsis "Low-level JSON library for OCaml")
(description "Yojson is an optimized parsing and printing library for the
JSON format. It addresses a few shortcomings of json-wheel including 2x
@@ -3551,7 +3552,8 @@ format}. @code{craml} is released as a single binary (called @code{craml}).")
(native-inputs
`(("ocaml-findlib" ,ocaml-findlib)))
(arguments
- '(#:tests? #f)) ;; Errors in tests in version 3.2.2
+ '(#:jbuild? #t
+ #:tests? #f)) ;; Errors in tests in version 3.2.2
(synopsis "Context sensitive completion for OCaml in Vim and Emacs")
(description "Merlin is an editor service that provides modern IDE
features for OCaml. Emacs and Vim support is provided out-of-the-box.