summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2019-10-28 23:53:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-30 10:17:52 +0100
commit3a2b1a3c9c3033345a091026d4299b0399d8f14c (patch)
tree4dadfdbb5309d8ec901fe7d52706ace5762b7d79 /gnu
parent8e5fbd5dda93e137ff527cabe25989b28ab9e1c0 (diff)
gnu: python-xlrd: Update to 1.2.0.
* gnu/packages/python-xyz.scm (python-xlrd): Update to 1.2.0. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f6347d7039..136c786102 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7247,21 +7247,23 @@ Supported netlink families and protocols include:
(define-public python-xlrd
(package
(name "python-xlrd")
- (version "1.0.0")
+ (version "1.2.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "xlrd" version))
(sha256
(base32
- "0s8hjiz01vbhy85xalrz0qlsmd9ypf36zjqrf97hh984spapvy0g"))))
+ "1ci93fda4n67qhdvfl16zasyxrpygzk53hs6m8z0rd4dxrnb6vjl"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; Current test in setup.py does not work as of 1.0.0, so use nose to
- ;; run tests instead for now.
- (replace 'check (lambda _ (invoke "nosetests"))))))
- (native-inputs `(("python-nose" ,python-nose)))
+ ;; Some tests depend on writing a temp file
+ ;; to the user's home directory
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (delete-file "tests/test_open_workbook.py")
+ #t)))))
(home-page "http://www.python-excel.org/")
(synopsis "Library for extracting data from Excel files")
(description "This package provides a library to extract data from