summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-10-19 10:04:35 -0700
committerVagrant Cascadian <vagrant@debian.org>2020-10-19 13:02:38 -0700
commit4d850f7c5a1ec773ef1d12dce4c1e1000819920d (patch)
tree56d9803a93036d052be22c9c7ffda20fda41e37d /gnu
parent19c14d95b3261dd54c56686b5d11ef8008e99620 (diff)
gnu: linux-libre-arm64-generic: Enable support for Pinebook.
* gnu/packages/linux (linux-libre-arm64-generic): Enable modules for display, battery, charger and usb on Pinebook.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9078b52467..43ffd39e62 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -978,7 +978,16 @@ It has been modified to remove all non-free binary blobs.")
#:extra-options
(append
`(;; needed to fix the RTC on rockchip platforms
- ("CONFIG_RTC_DRV_RK808" . #t))
+ ("CONFIG_RTC_DRV_RK808" . #t)
+ ;; Pinebook display, battery, charger and usb
+ ("CONFIG_DRM_ANALOGIX_ANX6345" . m)
+ ("CONFIG_CHARGER_AXP20X" . m)
+ ("CONFIG_INPUT_AXP20X_PEK" . m)
+ ("CONFIG_CHARGER_AXP20X" . m)
+ ("CONFIG_BATTERY_AXP20X" . m)
+ ("CONFIG_PINCTRL_AXP209" . m)
+ ("CONFIG_AXP20X_POWER" . m)
+ ("CONFIG_AXP20X_ADC" . m))
%default-extra-linux-options)))
(define-public linux-libre-arm64-generic-5.4