summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-14 05:44:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-22 01:06:02 +0100
commit5dca4c76ac02918546dae2300419d940571381d3 (patch)
tree563e4ae3f7b3b1163baf08573a6df1d992fa6e73 /gnu
parent34e8cf225cc380c2f248eecd43151f6751eeda97 (diff)
gnu: Add clzip.
* gnu/packages/compression.scm (clzip): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 543d8ab7b9..be82296ae6 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1969,3 +1969,29 @@ not compress them.
Lunzip is intended to be fully compatible with the regular lzip package.")
(license (list license:bsd-2 ; carg_parser.[ch]
license:gpl2+)))) ; everything else
+
+(define-public clzip
+ (package
+ (name "clzip")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.savannah.gnu.org/releases/lzip/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1brvsnpihzj81cf4wk2x5bnr2qldlq0wncpdbzxmzvxapm1cq2yc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "CC=gcc")))
+ (home-page "http://www.nongnu.org/lzip/clzip.html")
+ (synopsis "Small, stand-alone lzip compressor and decompressor")
+ (description
+ "Clzip is a compressor and decompressor for files in the lzip compression
+format (.lz), written as a single small C tool with no dependencies. This makes
+it well-suited to embedded and other systems without a C++ compiler, or for use
+in other applications like package managers.
+Clzip is intended to be fully compatible with the regular lzip package.")
+ (license (list license:bsd-2 ; carg_parser.[ch], lzd in clzip.texi
+ license:gpl2+))))