summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 11:28:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:57 +0100
commit5e2ad376848845ce114e97b24901a90a222ef939 (patch)
tree0abbbb84f8b4a11816ff5141d6397eb03827aebc /gnu
parent7dd1fbf9ee14dd534bbd7ce2b629d1a2f6333341 (diff)
gnu: Add r-imager.
* gnu/packages/cran.scm (r-imager): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1699abb85d..f5eaf88c1b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18232,3 +18232,45 @@ currently limited to 8 bit greyscale images and 24, 32 bit (A)RGB images.")
TIFF format bitmap images. Identification defaults to the use of the magic
number embedded in the file rather than the file extension.")
(license license:gpl2+)))
+
+(define-public r-imager
+ (package
+ (name "r-imager")
+ (version "0.41.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "imager" version))
+ (sha256
+ (base32
+ "19fqgjhg04garbipx20g72h9dd6k0jj4ac48nby6km4h665vrs4v"))))
+ (properties `((upstream-name . "imager")))
+ (build-system r-build-system)
+ (inputs
+ `(("fftw" ,fftw)
+ ("libtiff" ,libtiff)
+ ("libx11" ,libx11)
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-cairo" ,r-cairo)
+ ("r-downloader" ,r-downloader)
+ ("r-igraph" ,r-igraph)
+ ("r-jpeg" ,r-jpeg)
+ ("r-magrittr" ,r-magrittr)
+ ("r-plyr" ,r-plyr)
+ ("r-png" ,r-png)
+ ("r-purrr" ,r-purrr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-readbitmap" ,r-readbitmap)
+ ("r-stringr" ,r-stringr)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "http://dahtah.github.io/imager")
+ (synopsis "Image processing library")
+ (description
+ "This is a package for fast image processing for images in up to 4
+dimensions (two spatial dimensions, one time/depth dimension, one color
+dimension). It provides most traditional image processing tools (filtering,
+morphology, transformations, etc.) as well as various functions for easily
+analyzing image data using R. The package wraps @url{http://cimg.eu, CImg}, a
+simple, modern C++ library for image processing.")
+ (license license:lgpl3)))